Intermitencia en los servicios de PSE
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Dec 08, 2019 - 22:09 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Dec 08, 2019 - 21:13 GMT-05:00
This incident affected: Processors (ACH (CO)) and BackEnd (Transfer Service).