Error en transacciones a través de Datafast
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 11:32 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Feb 15, 2021 - 10:53 GMT-05:00
This incident affected: Ecuador Payment Processing (Datafast (EC)).