PSE procesador de tarjeta (Co) presenta alto porcentaje de rechazo de transacciones
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 08:42 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Jan 08, 2021 - 01:11 GMT-05:00
This incident affected: Colombia Payment Processing (ACH (CO)).