Problemas con transacciones procesadas por Credibanco (Colombia)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Sep 12, 2020 - 09:20 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Sep 11, 2020 - 09:52 GMT-05:00
This incident affected: Processors (Credibanco (COL)).