Problemas con transacciones procesadas por Credibanco (Colombia)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Sep 13, 2020 - 18:44 GMT-05:00
Update
We are continuing to investigate this issue.
Posted Sep 13, 2020 - 18:43 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Sep 12, 2020 - 09:21 GMT-05:00
This incident affected: Processors (Credibanco (COL)).