Banco de Crédito e Inversiones (BCI) se encuentra con problemas al procesar transacciones por el procesador ETPay (Chile)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 19:20 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Feb 18, 2021 - 15:49 GMT-05:00
This incident affected: Chile Payment Processing (ETPay (CH)).