Intermitencias ETPay Procesador Inalcanzable - Banco Itaú
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 12:15 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Jun 15, 2021 - 11:45 GMT-05:00
This incident affected: Processors (ETPay (CH)).