Transacciones procesadas por Credibanco (Colombia) caen en timeout
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Sep 06, 2020 - 12:09 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Sep 06, 2020 - 07:58 GMT-05:00
This incident affected: Colombia Payment Processing (Credibanco (CO)).