Transacciones a través de PSE - ACH de transferencias bancarias en Colombia con problemas a través del banco Bancolombia y Nequi
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 19:40 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Jan 15, 2021 - 15:44 GMT-05:00
This incident affected: Colombia Payment Processing (ACH (CO)).