Transacciones declinadas por PSE (Colombia)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 23:04 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Sep 17, 2020 - 22:36 GMT-05:00
This incident affected: Processors (ACH (CO)) and BackEnd (Transfer Service).