Intermitencia Processor Card Etpay (CH)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 16, 2022 - 01:08 GMT-05:00
Investigating
Se presenta alta tasa de transacciones declinadas por parte del procesador, se procede a notificar para su validación.
Posted Jan 15, 2022 - 22:31 GMT-05:00
This incident affected: Processors (ETPay (CH)).