Problemas con transacciones procesadas por Niubiz (Visanet) (Peru)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 06:12 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Feb 19, 2021 - 02:48 GMT-05:00
This incident affected: Peru Payment Processing (Visanet (PE)).