Transacciones de transferencia con ETPAY (Chile)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 11:03 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Jan 04, 2021 - 09:23 GMT-05:00
This incident affected: BackEnd (Transfer Service) and Processors (ETPay (CH)).