Pagos por SafetyPay Ecuador con el Banco Guayaquil se encuentran deshabilitado
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 16:57 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Jan 05, 2021 - 12:28 GMT-05:00
This incident affected: Processors (SafetyPay (EC)).