Banco de Crédito e Inversiones (BCI) se encuentra con problemas al procesar transacciones por el procesador ETPay (Chile)
Incident Report for Kushki
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 14:04 GMT-05:00
Investigating
We are currently investigating this issue.
Posted Dec 14, 2020 - 09:54 GMT-05:00
This incident affected: Chile Payment Processing (ETPay (CH)).